On 04.01.10 07:25, Yukihiro Matsumoto wrote:
> |Any thoughts on this feature request?
> |
> |  hello.singleton_class == (class << hello; self; end)
> |
> |Thanks for your consideration.
> 
> We haven't met any consensus of a name for the method.
> singleton_class, singletonclass, eigenclass, or whatever.
_why suggested "metaclass" back in 2005. But since we already have
#define_singleton_method and #singleton_methods, "singleton_class"
should be the name of it.

I'd like to see it included in future Ruby versions.

[murphy]