Issue #2484 has been updated by Yui NARUSE.


Requirement for cross compiling didn't clearly showed before you pointed.
And now, we put a current policy: if you use the same version you can cross compile; if you cannot, it is a bug.

Yes, current situation seems funny. But you know, current ruby core team can't check cross compiling status so often.
If you or someone can check and will create ticket every failure with a patch, please create feature request ticket.
----------------------------------------
http://redmine.ruby-lang.org/issues/show/2484

----------------------------------------
http://redmine.ruby-lang.org