Bug #2459: Cannot statically link ext/digest/sha2
http://redmine.ruby-lang.org/issues/show/2459

Author: Arnaud Fontaine
Status: Open, Priority: Normal
ruby -v: ruby 1.8.6 (2009-08-04 patchlevel 383) [i686-linux]

Hello,

Trying to build a static binary for ruby against OpenSSL library does not work if ext/digest/sha2 is enabled because SHA256_Transform and SHA512_Transform are already defined in OpenSSL library. I think this issue has already been reported on a blog before but I can't remember where. Anyway, the patch I have attached is pretty trivial. Moreover, this issue also affects ruby 1.8.7, should I submit a separate bug report against this version? Thanks.

Regards,
Arnaud Fontaine


----------------------------------------
http://redmine.ruby-lang.org