Issue #2247 has been updated by ѧ T..

File patch-ruby-openssl added

The attached new patch almost fixes the OpenSSL-extension. The bulk of it is casts from char* to unsigned char*
with some const-ification thrown in.

This should help concentrate on fixing /real/ problems, such as:

gcc44 -I. -I../.. -I/home/mteterin/ruby-1.8.7-p174 -I/home/mteterin/ruby-1.8.7-p174/ext/openssl -DRUBY_EXTCONF_H=\"extconf.h\"    -fPIC -O2 -Wall -Wno-unused -Werror -pipe -march=nocona   -c /home/mteterin/ruby-1.8.7-p174/ext/openssl/ossl_pkey_dh.c
cc1: warnings being treated as errors
ext/openssl/ossl_pkey_dh.c: In function 'ossl_dh_initialize':
ext/openssl/ossl_pkey_dh.c:173: error: function called through a non-compatible type
ext/openssl/ossl_pkey_dh.c:173: note: if this code is reached, the program will abort
ext/openssl/ossl_pkey_dh.c: In function 'ossl_dh_to_public_key':
ext/openssl/ossl_pkey_dh.c:333: error: function called through a non-compatible type
ext/openssl/ossl_pkey_dh.c:333: note: if this code is reached, the program will abort
make: *** [ossl_pkey_dh.o] ާڧݧܧ 1

The above problems -- triggered in several files -- seem to be with OpenSSL, rather than Ruby or its openssl-extension. I'm unsure, if any work-around is possible. These are NOT fixed by the attached patch.
----------------------------------------
http://redmine.ruby-lang.org/issues/show/2247

----------------------------------------
http://redmine.ruby-lang.org