Bug #2222: Regex creation error in safe mode
http://redmine.ruby-lang.org/issues/show/2222

Author: Marc-Andre Lafortune
Status: Open, Priority: High
Category: core, Target version: 1.9.2
ruby -v: ruby 1.9.2dev (2009-10-17 trunk 25379) [x86_64-darwin10.0.0]

$ ruby -e '$SAFE=4; /#{}/o'
-e:1:in `<main>': Insecure: can't modify array (SecurityError)


Fairly recent since error not present in ruby 1.9.2dev (2009-08-30 trunk 24705)


----------------------------------------
http://redmine.ruby-lang.org