It seems to me that some redundancy in the Net::FTP module can be
reduced.  Currently we have these methods:

getbinaryfile
gettextfile
putbinaryfile
puttextfile
retrbinary
retrlines
storbinary
storlines

In each case the argument list is the same.  Wouldn't it be nicer if we
just added a ".bin" class method that you could set to true or false?
The we could reduce it from the above 8 methods to just 4, i.e.

get
put
retr
stor

And they would do the right thing based on whether Net::FTP.bin was set
to true or false.  Also, it's less typing. :)

Just a thought.

Regards,

Dan