Issue #2105 has been updated by Luis Lavena.


Emmanuel:

You installed a binary version of a gem, which was built for Ruby 1.8.x, not 1.9.

Because of that, the execution of that gem or it's binary extensions is going to fail on 1.9.

Since this is related to mongrel, I'm going to go even more deep in my response:

1) There is no official 1.9 release of mongrel that builds cleaning, except for my fork at GitHub
2) Even so, some tests and some code needs to be changed to accommodate proper threading and functionality.
3) Conversations about Mongrel 2.0 with better support for above cases and Rack has been started, but no progress has been made.
4) There is no ETA when the above issues will be fixed.

This is not a Ruby bug, but a 3rd party library one.

I know all the above doesn't help you solve the problem, but please refer to my blog and search for it:

http://blog.mmediasys.com
--
Luis Lavena

----------------------------------------
http://redmine.ruby-lang.org/issues/show/2105

----------------------------------------
http://redmine.ruby-lang.org