Bug #2094: prime.rb has warning.
http://redmine.ruby-lang.org/issues/show/2094

Author: David Brown
Status: Open, Priority: Normal
Category: lib
ruby -v: ruby 1.9.2dev (2009-07-18 trunk 24186) [x86_64-linux]

The following program:

$VERBOSE = true
require 'prime'
42.prime?

prints a warning:
/var/tmp/ruby-1.9.2-preview1/lib/ruby/1.9.1/prime.rb:261: warning: instance variable @ubound not initialized

I've tried with 1.9.1 released and with this preview release.  The
warning is printed repeatedly for each primality check.


----------------------------------------
http://redmine.ruby-lang.org