Hi,

In message "Re: [ruby-core:25461] Re: [Feature #2032] Change the license to "GPLv2+ 	or Ruby's original"."
    on Tue, 8 Sep 2009 07:35:38 +0900, Gregory Brown <gregory.t.brown / gmail.com> writes:

|> And as Shyouhei said, I am afraid that the following can have a license problem.
|> $ ruby -r readline -r openssl
|> Because ... <snip>
|
|I think this all makes sense.  If you switch to MIT/BSD this problem
|goes away, so long as you keep in mind that distributors of Ruby are
|still in effect bound by the terms of the GPL.  So you don't gain
|anything there and still need to be vigilant about linking...

The problem would not go away, since it's conflict between openssl and
readline.

And, remember the quoted statements are very old (6+ years), I am not
particularly changing the license right now, unless there will be huge
gain, valuable more than cumbersome works of changing license.

							matz.