Hi,

In message "Re: [ruby-core:25184] Re: [Feature #1961] Kernel#__dir__"
    on Sun, 30 Aug 2009 04:10:55 +0900, Hongli Lai <hongli / plan99.net> writes:

|I think it should be __DIR__ for consistency. There are no other __ things in Ruby
|that are lowercase. I think whether __dir__ is a keyword or a function should be an
|implementation detail.

On 1.9, we have __method__ and __callee__ lowercase for the same reason.

							matz.