On Aug 29, 2009, at 12:10 , Hongli Lai wrote:

> I think it should be __DIR__ for consistency. There are no other __  
> things in Ruby
> that are lowercase. I think whether __dir__ is a keyword or a  
> function should be an
> implementation detail.

 >> nil.methods.grep(/__/)
=> ["__send__", "__id__"]