Issue #1857 has been updated by Mark Moseley.


This is becoming more and more of a problem; people are trying to install the 1.9 ruby-debug and getting the vm_core.h not found error. So I'm going to tackle creating a gem to do this.

Here's my idea: at the time extconf.rb runs for linecache or ruby-debug-base, pull the Ruby sources from ftp.ruby-lang.org based on the current RUBY_VERSION and RUBY_PATCHLEVEL. Decompress, pull out *.h and *.inc, put it into a directory, and then proceed with the build. All of this in pure Ruby so I don't have to worry about wget or tar on Windows.

If anyone can think of a better approach, please let me know. I don't want this to be something that I have to maintain with every Ruby release.

----------------------------------------
http://redmine.ruby-lang.org/issues/show/1857

----------------------------------------
http://redmine.ruby-lang.org