Issue #1090 has been updated by Dylan Hunter.


Not sure that this is closed / feedback level, (or at least, if it is, the above still hasn't fixed the issue for me).

Just built ruby-1.9.1-p129 from source on Ubuntu 9.04.  And although the periods after each line in the build were mutated, (i.e. capital and lower-case C's and m's, rather than periods) finally got it installed.  "gem -v" responds properly as 1.3.1, but if I try to "gem list" / "gem update," etc. I get what looks to be the same response Jerome received above.  Tried to install the zlib packages suggested above, no dice.  Installed, (or at least tried to install - 2 of the packages, zlib1 & zlib1-dev, said they were no longer avail) every other package in the jaunty repositories that start with "zlib," (i.e. zlib1, zlib1-dev, zlib1g, zlib1g-dbg, zlib1g-dev, zlib-bin, zlibc, zlib-gst) and same set of error lines every time.

Since installing anywhere near recent versions of Ruby will probably forever be this manual build from source on any debian-based distros, at least, (i.e. the only version of 1.9 in the repos is 1.9.0 in the regular, and, even as of 2009-07-15, only 1.9.1.0-1 in the highly non-recommended debian experimental repo) any help would be most appreciated.

Thanks,

Dylan
----------------------------------------
http://redmine.ruby-lang.org/issues/show/1090

----------------------------------------
http://redmine.ruby-lang.org