Issue #1742 has been updated by Marcus Rückert.


or just disable -O2, which fixes the build aswell. from my spec file:


touch -r configure configure.timestamp
perl -p -i.bak -e 's|-O2|-O0|g' configure
diff -urN configure{.bak,} ||:
touch -r configure.timestamp configure

afterwards 1.9 builds on 11.0 aswell.

----------------------------------------
http://redmine.ruby-lang.org/issues/show/1742

----------------------------------------
http://redmine.ruby-lang.org