Bug #1753: non success open client socket not detected on windows
http://redmine.ruby-lang.org/issues/show/1753

Author: regis d'aubarede
Status: Open, Priority: Normal
ruby -v: 1.9.1

Here the code and execution with different ruby version :


D:\usr\ruby\local\dsd17>type z_essai.rb
require 'socket'

p "*************************************************"
p [RUBY_PLATFORM,RUBY_VERSION,RUBY_RELEASE_DATE]
p "*************************************************"
p "Before openning client socket on non existant server"
begin
  TCPSocket.open("localhost",4444) { |io| p [io,io.closed?]  }
  p "after openning client socket on non existant server"
rescue
  p "good, non connection is detected"
  p $!
end
p "*************************************************"


D:\usr\ruby\local\dsd17>ruby z_essai.rb
"*************************************************"
["i386-mswin32", "1.8.6", "2007-03-13"]
"*************************************************"
"Before openning client socket on non existant server"
"good, non connection is detected"
#<Errno::EBADF: Bad file descriptor - connect(2)>
"*************************************************"

D:\usr\ruby\local\dsd17>jruby z_essai.rb
"*************************************************"
["java", "1.8.6", "2009-06-15"]
"*************************************************"
"Before openning client socket on non existant server"
"good, non connection is detected"
#<Errno::ECONNREFUSED: Connection refused - Connection refused>
"*************************************************"


D:\usr\ruby\local\dsd17>ruby19 z_essai.rb
"*************************************************"
["i386-mswin32", "1.9.1", "2009-01-30"]
"*************************************************"
"Before openning client socket on non existant server"
[#<TCPSocket:0xabf914>, false]
"after openning client socket on non existant server"
"*************************************************"

D:\usr\ruby\local\dsd17>


----------------------------------------
http://redmine.ruby-lang.org