On Tue, Jul 7, 2009 at 12:12 AM, NARUSE, Yui<naruse / airemix.jp> wrote:
> Sorry for late response,
>
> [...]
>
> So I want to bundle SQLite with Ruby.
> But sqlite3-ruby is not maintained now.
> Amalgalite is too big.
> Amalgalite::SQLite has suitable scope but its style is not Ruby way.
> (for example the usage of methods with !.)
>

I've worked on a spinoff version of sqlite3-ruby, to offer binary
versions for Windows using a concept called "fat binaries" to allow
Ruby 1.8 and 1.9 coexist in the same gem.

But I still think that bundling sqlite3-ruby into Ruby itself is going
to slowdown the progress and release cycle of the extension, not
taking in consideration it adds another layer of complexity for the
ones that build Ruby from source (me).

This also will impose a issue for implementations like JRuby, since
this put more work on the team to be able to replicate everything
under the sun of what MRI does.

-- 
Luis Lavena
AREA 17
-
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupy