Hi,

In message "Re: [ruby-core:23253] Re: [Feature #666](Rejected) Enumerable::to_hash"
    on Sun, 19 Apr 2009 08:52:54 +0900, trans <transfire / gmail.com> writes:

|I don't see why a corresponance in needed. It's simply a
|transformation.

#to_hash (or whatever name of the method) can only transform
enumerable in certain format, e.g. enumerable of two-elements arrays.
I think this is too much assumption for a method of Enumerable.

OK, I admit we already have some methods with presumption, e.g.
#sort, #min and #max to assume elements to be comparable, but their
usefulness is proven in the history of the language.  Meanwhile, how
often do we need #to_hash?  I haven't, at least.

|I think the real problem lies in the name of the
|method proposed. Rather than #to_hash, for instance, in Facets this
|method is called #graph or #mash (for "map hash"). Maybe there is a
|better name to be had, but it certainly is a useful method to have at
|times.

Any method can be useful for certain situation.  The point is how
often and in what situation it is useful.  I don't see that much
usefulness to make it built in.

							matz.