On Apr 18, 8:07   
> Issue #666 has been updated by Yukihiro Matsumoto.
>
> Status changed from Open to Rejected
>
> Enumerable in general does not correspond with mappings, so that I feel Enumerable#to_hash is improper.

I don't see why a corresponance in needed. It's simply a
transformation. I think the real problem lies in the name of the
method proposed. Rather than #to_hash, for instance, in Facets this
method is called #graph or #mash (for "map hash"). Maybe there is a
better name to be had, but it certainly is a useful method to have at
times.

T.