Hi,

In message "Re: [ruby-core:22322] Re: YASNP (Yet Another Selector Namespace	Proposal)"
    on Sun, 22 Feb 2009 11:35:41 +0900, Aaron Patterson <aaron / tenderlovemaking.com> writes:

|+1 as well, but I like the block.  For me, it seems to be more clear as
|to what is going on.
|
|  use Merb::String => String do
|    "bla blah".some_special_merb_only_method
|  end
|
|  "bla blah".some_special_merb_only_method # => doh!  doesn't exist

+1 to have some kind of selector namespace (it's planned for 2.0
anyway), but -1 for using block (or block-like syntax) to denote
namespace scope, because

  * it's not really a block
  * too small granularity for namespace switching might bring confusion

I'd prefer per file namespace switching.


							matz.