On Wednesday 11 of February 2009 19:42:37 John Barnette wrote:
> hyperbole. I'd appreciate it you'd reply to this thread with specific
> problems you've encountered in 1.8.7, especially problems that have
> kept you from upgrading.

Sorry for a little late response... So, i have one small story, from several 
months ago, when i was just starting with ruby. I had a small program written 
(~200 lines), and i decided to give 1.8.7 a try. It failed on Array#index 
change. Thoughts:

1. I didn't expect ruby to have "kernel-like" versioning scheme, so i was 
quite shocked that 1.8.7 changed an important class in such a way. It looked 
like there could be a lot more _big_ changes and i decided to stay with 1.8.6

2. I didn't read NEWS. Actually i had no idea there's a NEWS file which 
actually had useful content, and that it's the place where changes to ruby N-1 
would live. Perhaps it's just me... but it was quite surprising to learn. 

  -- Michal