On Thu, Feb 12, 2009 at 04:01:58AM +0900, Gregory Brown wrote:
> On Wed, Feb 11, 2009 at 1:42 PM, John Barnette <jbarnette / gmail.com> wrote:
> > There's a fair amount of talk lately about release management and
> > version stability, most of it stemming from the way the release of
> > Ruby 1.8.7 was handled. Despite all the talk, I haven't seen a good
> > list of problems with 1.8.7 that's not buried in a fair amount of
> > hyperbole. I'd appreciate it you'd reply to this thread with specific
> > problems you've encountered in 1.8.7, especially problems that have
> > kept you from upgrading.
> >
> > Let's try to avoid the philosophical disagreements around backporting
> > new features, etc, and stick to specific bugs and technical problems,
> > okay? There are plenty of other threads that cover all that. :)
> 
> When I initially tried running Ruport's tests on 1.8.7, there were
> some failures.  I don't remember the specifics, so that probably only
> half counts.
> 
> As a project maintainer, I wish to maintain 1.8.6 compatibility in my
> projects (Prawn, Ruport, etc).  I am already supporting Ruby 1.9 as
> well in Prawn and will do so in Ruport.  But to support 1.8.7+, I'd
> need to add a third branch to that already ugly version-selection
> logic.  Without that, when  a patch is submitted to me that depends on
> a Ruby 1.8.7 feature, it might slip through the cracks and break my
> 1.8.6 compatibility.  I really do not want to run tests on 1.8.6,
> 1.8.7 *and* 1.9.1 each time, even if there are tools out there that
> make this easier.

I can't agree with this at all.  If you refuse to run your tests
against any particular version of ruby, how can you say you support
that version?

  $ rake multi  # <= That's it!

To bring this thread back on topic; what code, specifically, are you using
that needs to be different for 1.8.6, 1.8.7, and 1.9?

I would like to see some concrete examples of breakage.

-- 
Aaron Patterson
http://tenderlovemaking.com/