On Wed, Feb 11, 2009 at 5:55 PM, Charles Oliver Nutter
<charles.nutter / sun.com> wrote:
> Luis Lavena wrote:
>>
>> Even AST generated by 1.8.6-p287 differs from 1.8.6-p114, something
>> like that could break ParseTree and Ruby2Ruby.
>
> FWIW, parsetree-like tools are *always* going to face this problem from
> version to version, and will require constant updating. That's a primary
> reason we have not moved to support PT in JRuby...we change our AST fairl=
y
> often.

Thank you Charles for sharing the point of view from JRuby side.

I'm aware of that PT tools will phase these issues, and tools that
leverage directly into VM Instructions too.

I've just provided my comments on what I saw from 1.8.7 and some of
the backports to p287 in 1.8.6 branch.

I'm worried about this as maintainer of One-Click Installer get lot of
emails and questions about moving to a newer version and support and
fix the bugs of not just Ruby but all the packages bundled with the
installer (fyi, is 10 hours of QA every new release).

Regards,
--=20
Luis Lavena
AREA 17
-
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exup=E9ry