Hi,

In message "Re: [ruby-core:21977] Re: New hash : syntax for the 1.8 series?"
    on Wed, 11 Feb 2009 10:33:56 +0900, Evan Phoenix <evan / fallingsnow.net> writes:

|This causes massive confusion and doubt about ruby. When a user  
|upgrades to 1.8.7 and a significant amount of code begins to fail,  
|they worry. When the upgrade to 1.8.8 and discover they've been using  
|new syntax that their coworkers don't have, they get worried.

As for 1.8.7, it was unfortunate to break Rails at the beginning, but
"significant amount" is overrated, as far as I understand.  The
problems were Rails design was bit weak for name conflict, and more
importantly, NO ONE ever had tried to check Rails on 1.8.7 RC during
the release candidate time. I had talked with DHH and people behind
REE after that, to ask for help when 1.8.8 will out.  We will see less
problems, I hope.

							matz.