Bug #1039: test-all fails without installation
http://redmine.ruby-lang.org/issues/show/1039

Author: Tadashi Saito
Status: Open, Priority: Normal
Target version: 1.9.1

In the current state of ruby_1_9_1, some tests in `make test-all` fails when I didn't `make install`.


  1) Failure:
test_class_build_extconf_fail(TestGemExtExtConfBuilder) [/home/tadashi/svn/ruby/ruby_1_9_1/test/rubygems/test_gem_ext_ext_conf_builder.rb:66]:
Expected /\Aextconf failed:

\/usr\/local\/bin\/ruby1.9 extconf.rb.*
checking for main\(\) in .*?nonexistent/m to match "extconf failed:\n\n/usr/local/bin/ruby1.9 extconf.rb\nsh: /usr/local/bin/ruby1.9: No such file or directory\n".

  2) Error:
test_class_build(TestGemExtExtConfBuilder):
Gem::InstallError: extconf failed:

/usr/local/bin/ruby1.9 extconf.rb
sh: /usr/local/bin/ruby1.9: No such file or directory

    /home/tadashi/svn/ruby/ruby_1_9_1/test/rubygems/test_gem_ext_ext_conf_builder.rb:24:in `block in test_class_build'
    /home/tadashi/svn/ruby/ruby_1_9_1/test/rubygems/test_gem_ext_ext_conf_builder.rb:23:in `chdir'
    /home/tadashi/svn/ruby/ruby_1_9_1/test/rubygems/test_gem_ext_ext_conf_builder.rb:23:in `test_class_build'

  3) Failure:
test_build_extensions_extconf_bad(TestGemInstaller) [/home/tadashi/svn/ruby/ruby_1_9_1/test/rubygems/test_gem_installer.rb:75]:
Expected /\/usr\/local\/bin\/ruby1\.9: No such file/ to match "/usr/local/bin/ruby1.9 extconf.rb\nsh: /usr/local/bin/ruby1.9: No such file or directory\n".


Is this the spec?


----------------------------------------
http://redmine.ruby-lang.org