Issue #999 has been updated by William Mason.


Please cross-reference to GEM bug:

   [#23515] gem install not working with ... ruby-1.9.1-preview1-i386-mswin32

I'll repeat the lazy work-around hack that I used:

Take the following DLL-s from the working 1.8 installation:

   *  ZLIB1.DLL  as -->  ruby-1.9.1-preview1-i386-mswin32\bin\ZLIB.DLL

And Copy 

   *  SLEAY32.DLL
   *  libeay32.dll
   *  readline.dll

Again, if the preview can't be mad to include appropriate DLL-s, then at least instructions on how to acquire them ought to be included in the read-me.  After all there's a good chance that there could be incompatibilities between the DLL versions from v1.8 and the new release.

w.
----------------------------------------
http://redmine.ruby-lang.org/issues/show/999

----------------------------------------
http://redmine.ruby-lang.org