Issue #1008 has been updated by Luis Lavena.


On 1.8, the only that bring basic ruby scripts into the plate was One-Click Installer.

By default, Ruby generates and bundles those into the batch file stubs. One-Click installer separate those to ease management and also to match how RubyGems implement it.

That's one of the reasons you only have .bat for the bundled gem, rake and ruby scripts, and get the 2 files for ones installed with rubygems.

I believe there are reasons for that, but couldn't find neither in the code or the documentation.
----------------------------------------
http://redmine.ruby-lang.org/issues/show/1008

----------------------------------------
http://redmine.ruby-lang.org