It's really small and simple bug, please commit it if it makes sense (ruby-core:20485)

Thanks,

http://redmine.ruby-lang.org/issues/show/859

--Roman
P.S. For bugs like this, should it be opened in ruby 1.8, 1.8.7 or 1.9?