Bug #980: Requiring erb produces two warnings in 1.9.1-RC1
http://redmine.ruby-lang.org/issues/show/980

Author: Alex Legler
Status: Open, Priority: Low
Category: lib
Reproducible Version: 1.9.1 RC1

When requiring erb with 1.9.1 RC1 or trunk with -w these two warnings are shown:

-:1: warning: encoding 'UTF-8' is ignored, valid only in the first line except for shebang line.
-:1: warning: encoding 'Big5' is ignored, valid only in the first line except for shebang line.

It seems that two "-*- coding" lines in the rdoc in line 68 and 72 of lib/erb.rb are interfering.


----------------------------------------
http://redmine.ruby-lang.org