Issue #888 has been updated by Chauk-Mean PROUM.


> If you're building Ruby with VC9 (VS2008) then you need to also build zlib with VC9.
Of course, that's what I've done. Please take a look at my initial bug report.

> Daniel Berger had problems building zlib with VC8/9 too.
I had no problem with building zlib in itself. 
Ruby works also fine with zlib (all tests in test/zlib passed successfully).
The problem I had was related with Rubygems.
This is now fixed thanks to the patch from Yasuhiro.

> Why don't you try MinGW (GCC)?
I also use MinGW and I have other problems at the moment related with wxWidgets ...
I patched MinGW and wxWidgets for the GDI+ support, some samples work fine, others don't work (e.g. RichTextCtrl).
Hopefully, this doesn't prevent the correct build of the wxRuby gem.

Conversely, I have no problem with the VS 2008 build of wxWidgets.

Chauk-Mean.

----------------------------------------
http://redmine.ruby-lang.org/issues/show/888

----------------------------------------
http://redmine.ruby-lang.org