Here's a recent test-all output for 1_8_6 branch, if anybody can help
out with any of these that would be much welcome :)

 1) Failure:
test_client_auth(OpenSSL::TestSSL)
   [../ruby_1_8/test/openssl/test_ssl.rb:157:in `test_client_auth'
    ../ruby_1_8/test/openssl/test_ssl.rb:73:in `call'
    ../ruby_1_8/test/openssl/test_ssl.rb:73:in `start_server'
    ../ruby_1_8/test/openssl/test_ssl.rb:156:in `test_client_auth']:
<OpenSSL::SSL::SSLError> exception expected but was
Class: <Errno::ECONNRESET>
Message: <"An existing connection was forcibly closed by the remote host.">
---Backtrace---
../ruby_1_8/test/openssl/test_ssl.rb:160:in `connect'
../ruby_1_8/test/openssl/test_ssl.rb:160:in `test_client_auth'
../ruby_1_8/test/openssl/test_ssl.rb:157:in `test_client_auth'
../ruby_1_8/test/openssl/test_ssl.rb:73:in `call'
../ruby_1_8/test/openssl/test_ssl.rb:73:in `start_server'
../ruby_1_8/test/openssl/test_ssl.rb:156:in `test_client_auth'
---------------

 2) Failure:
test_del_trailing_separator_25(TestPathname)
[../ruby_1_8/test/pathname/test_pathname.rb:27]:
del_trailing_separator("\225\\\\").
<"\225\\"> expected but was
<"\225">.

 3) Failure:
test_should_propagate_signaled(TestBeginEndBlock)
[../ruby_1_8/test/ruby/test_beginendblock.rb:83]:
<nil> expected but was
<3>.

 4) Failure:
test_cgi(TestWEBrickCGI)
   [../ruby_1_8/test/webrick/test_cgi.rb:27:in `test_cgi'
    C:/dev/rubyinstallercheckout/sandbox/ruby_1_8/lib/net/http.rb:1053:in
`request'
    C:/dev/rubyinstallercheckout/sandbox/ruby_1_8/lib/net/http.rb:2136:in
`reading_body'
    C:/dev/rubyinstallercheckout/sandbox/ruby_1_8/lib/net/http.rb:1052:in
`request'
    C:/dev/rubyinstallercheckout/sandbox/ruby_1_8/lib/net/http.rb:1037:in
`request'
    C:/dev/rubyinstallercheckout/sandbox/ruby_1_8/lib/net/http.rb:543:in
`start'
    C:/dev/rubyinstallercheckout/sandbox/ruby_1_8/lib/net/http.rb:1035:in
`request'
    ../ruby_1_8/test/webrick/test_cgi.rb:26:in `test_cgi'
    ../ruby_1_8/test/webrick/utils.rb:38:in `call'
    ../ruby_1_8/test/webrick/utils.rb:38:in `start_server'
    ../ruby_1_8/test/webrick/utils.rb:46:in `start_httpserver'
    ../ruby_1_8/test/webrick/test_cgi.rb:17:in `test_cgi']:
<"/\244\333\244\262/\244\333\244\262"> expected but was
<"/\017U\017\375/\017U\017\375">.

1589 tests, 15093 assertions, 4 failures, 0 errors
make: *** [test-all] Error 1



And on 1.9:
................................................F..................................F........................................................................................................EE..E.EE.E......................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................F...................................................................................................................................................................................................F..............................................................................................................................................E.E....E.EEE.EE.E............................................................................................F............F............................................................................................................................................................................................F...................................................................................................................................................................................................................................F.F..................................EEFEFEEC:/dev/downloads/snapshot/lib/minitest/unit.rb:473:in
`public_instance_methods': failed to allocate
memory (NoMemoryError)
       from C:/dev/downloads/snapshot/lib/minitest/unit.rb:473:in
`test_methods'
       from C:/dev/downloads/snapshot/lib/minitest/unit.rb:407:in
`block in run_test_suites'
       from C:/dev/downloads/snapshot/lib/minitest/unit.rb:406:in `each'
       from C:/dev/downloads/snapshot/lib/minitest/unit.rb:406:in
`run_test_suites'
       from C:/dev/downloads/snapshot/lib/minitest/unit.rb:386:in `run'
       from C:/dev/downloads/snapshot/lib/minitest/unit.rb:330:in
`block in autorun'
make: *** [test-all] Error 1


Thanks!
-=r
-- 
2 Timothy 1:7