On Dec 18, 2008, at 6:23 PM, Yukihiro Matsumoto wrote:

> But I'd prefer adding a new class methodfor the purpose,
> say. String#buffer(n), to adding new role to an argument by type,
> or there may be a better name.

Maybe

   str = String.capacity(n)

or

   str = String.sized(n)

(presumably n is in bytes, not characters)