Issue #863 has been updated by Brian Candler.


Which Ruby? Which Ubuntu? Which OpenSSL?

I had no problems building ruby-1.9.1 preview1 and preview2 under Ubuntu Hardy with stock openssl (0.9.8g-4ubuntu3.3)

I also didn't have to hack ext/Setup. I just did ./configure --program-suffix=19

$ irb19
irb(main):001:0> require 'openssl'
=> true
irb(main):002:0> OpenSSL::SSL::VERIFY_PEER
=> 1
irb(main):003:0> 

Did you remember to install the libssl-dev package first?

What does ext/openssl/mkmf.log show?

----------------------------------------
http://redmine.ruby-lang.org/issues/show/863

----------------------------------------
http://redmine.ruby-lang.org