Rados?aw Bu?at wrote:
> I attempt to use ruby1.9 from trunk to have fun with it or just try.
> But sometimes I get like this:
> 
> /home/radarek/opt/lib/ruby1.9/gems/1.9.0/gems/nokogiri-1.0.6/lib/nokogiri/xml/node.rb:56:
> [BUG] unknown type 0x22 (0xc given)
> ruby 1.9.0 (2008-11-14 revision 20235) [x86_64-linux]
> 
...
> As you see I get useless info and only one function call is present.
> Am I doing it wrong or it's ok? Maybe should I compile ruby with
> special CFLAGS or other options? Any ideas?

1) Same binary?
2) Can you try it with gdb?

BTW it's seems GC problem.  Does nokogiri use C extension?

-- 
// SASADA Koichi at atdot dot net