Yukihiro Matsumoto wrote:
> * the name.  In Ruby, unlike Java, we rarely use the verb get for
>   method names.  We prefer foo to get_foo, when foo can be considered
>   as an attribute.  But in this case, args instead of get_args sounds
>   bit weird to me.

How about calling it "parameters"? The argument is the value that gets 
passed while the parameter is part of the method's declaration. From 
http://en.wikipedia.org/wiki/Parameter_(computer_science):

   "A parameter represents a value that the procedure expects you to 
supply when you call it. The procedure's declaration defines its parameters.
   ...
   An argument represents the value you supply to a procedure parameter 
when you call the procedure."

The word "parameter" would make more sense than "argument" in this case.