Hi,

In message "Re: [ruby-core:19627] Re: [Bug 1.9] gem_prelude.rb always require rubygems"
    on Thu, 30 Oct 2008 12:12:02 +0900, Nobuyoshi Nakada <nobu / ruby-lang.org> writes:

|> Yes, please.  It will be much better.  
|
|It will still require "rubygems/defaults/operating_system" and
|"rubygems/defaults/#{RUBY_ENGINE}".  Not good.

It works anyway.  It's much better than not working.

However, not all programs use RubyGems.  gem_prelude can be a burden
for those programs.  It might hinder benchmarks for example.
Honestly, I want gem_prelude to be as light as possible.

							matz.