Hi,

By recent change, gem_prelude always requires rubygems/defaults.rb and
other rubygems related files.  It's not my intention.  I don't want
the bare interpreter to rely on other libraries, until it's really
needed.  Plain execution should be done without loading any other
libraries.  That's the very reason behind pre-loaded prelude.rb and
gem_prelude.rb.  It already made my testing difficult.

So, Eric, could you avoid mandatory requiring rubygems from
gem_prelude, please?  It should be done lazily.

							matz.