Hi,

In message "Re: Errors building 1.8.1p3"
    on 03/12/09, Nathaniel Talbott <nathaniel / talbott.ws> writes:

|Oops... I just discovered that the error is something that occurred due 
|to my upgrade process. The warnings remain a problem, however.

Warnings are caused by conflicts in files asm/sigcontext.h and
linux/complier.h, both of which belong to the system.  I believe (and
want to believe) it's not caused by the Ruby source.

							matz.