On Sep 30, 9:58=A0am, "Meinrad Recheis" <meinrad.rech... / gmail.com>
wrote:
> On Thu, Sep 25, 2008 at 8:49 PM, Ryan Davis <ryand-r... / zenspider.com>wro=
te:
>
>
>
>
>
> > On Sep 25, 2008, at 03:33 , daz wrote:
>
> > =A0Respect for defending the English language, Ryan, but this is Ruby.
>
> >> Note this oddity in English grammar:
>
> >> =A01) It [singular] raises.
> >> =A02) They [plural] raise.
>
> > We're talking about assertions in unit tests here. There is never a plu=
ral
> > subject.
>
> > assert_raises reads correctly for both singular and multiple arguments:
>
> > assert (that it) raises (a) SyntaxError.
> > assert (that it) raises (one of) SyntaxError or ArgumentError.
>
> it depends entirely how you imagine the "missing" words. one could also r=
ead
> it like this:
>
> assert (the block to) raise (an) Exception
>
> This is, of course, absurd. What I am trying to say is that we should rea=
d
> method names as artificial commands and not as abbreviated English
> sentences. I'd prefer assert_exception over assert_raise and that over
> assert_raises.

OMG! Just leave it alone. I don't want to have to fix my tests over
something so pedantic.

T.