Hi,

In message "Re: [PATCH] multiple exceptions for assert_raises"
    on 03/12/05, Nathaniel Talbott <nathaniel / talbott.ws> writes:

|Guess I missed it. Oh well. If I wasn't so lazy myself I'd suggest that 
|someone should document these things :-/

Should have been written somewhere.  Maybe in the FAQ.

|So #has_key? will become #have_key? Or something else? Just out of 
|curiosity, why have you settled on this rule? At least for these cases, 
|it seems to cut down on readability. If you've already answered that 
|question, feel free to point me at a mailing list thread.

We have "key?" and "value?" for Hash.
The reason is mostly because I'm not an English speaker.  I sometimes
feel weird when I see code like:

  members.has_key?("foo")

|Anyhow, I will rename the primary method to #assert_raise, and alias 
|that method to the current #assert_raises. In 1.9, I will add a warning 
|for #assert_raises, and in 2.0 it will disappear.

Thank you.

							matz.