Hi,

In message "Re: [ruby-core:18889] Re: [ANN] Ruby 1.9.1 feature freeze"
    on Thu, 25 Sep 2008 17:19:58 +0900, SASADA Koichi <ko1 / atdot.net> writes:

|> I've rolled Nobu's change back, pending more dialog on the topic. My
|> preference is to have assert_raises and deprecate assert_raise. Barring
|> that, assert_raise could be an alias and stick around for those folk who
|> prefer it.
|
|I want to ask Matz about it (naming policy).

Basically, the method names in ruby use plain form if they are verbs.
Ruby is not English, nor Ruby does not belong to English speaking
people (although it uses a lot of English words).

If you want to change the basic rule, we should discuss before
changing it.  Or choose alternative name like #assert_exception,
which I like better.

							matz.