On Sep 25, 2008, at 3:19 AM, SASADA Koichi wrote:

>> I've rolled Nobu's change back, pending more dialog on the topic. My
>> preference is to have assert_raises and deprecate assert_raise.  
>> Barring
>> that, assert_raise could be an alias and stick around for those  
>> folk who
>> prefer it.
>
> I want to ask Matz about it (naming policy).

In this case, I agree with Ryan: assert_raises reads better.

I don't think I'd support assert_raise as an alias: mini/test is  
already a big break with test unit, and there's no need to even  
pretend to be compatible, so we may as well use the correct names.


Dave