On Dec 4, 2003, at 12:24, Yukihiro Matsumoto wrote:

> |> By the way "assert_raises" looks against the "plain form noun" rule 
> of
> |> Ruby (i.e. exist? instead of exists?).  Can you prepare 
> "assert_raise"
> |> alias to it, Nathaniel?
> |
> |Hmmm... I wasn't aware of the rule. Is it documented somewhere?
>
> No.  I mentioned the rule on the ruby-talk list several times though.

Guess I missed it. Oh well. If I wasn't so lazy myself I'd suggest that 
someone should document these things :-/


> You don't have to remove assert_raises in the near future, when we
> still have "has_key" method.  Perhaps deprecation will be taken place
> in 1.9, and they will be removed in 2.0.

So #has_key? will become #have_key? Or something else? Just out of 
curiosity, why have you settled on this rule? At least for these cases, 
it seems to cut down on readability. If you've already answered that 
question, feel free to point me at a mailing list thread.

Anyhow, I will rename the primary method to #assert_raise, and alias 
that method to the current #assert_raises. In 1.9, I will add a warning 
for #assert_raises, and in 2.0 it will disappear.


Nathaniel

<:((><