Ryan Davis wrote:
> 
> I just saw that Nobu rolled the undeprecated name from assert_raises to 
> assert_raise. Unfortunately the deprecation was NOT a typo and is 
> intentional. It is both a better English word choice and it is more 
> consistent with the other assertions (assert_includes, assert_throws, etc).
> 

Respect for defending the English language, Ryan, but this is Ruby.

Note this oddity in English grammar:

    1) It [singular] raises.
    2) They [plural] raise.

http://www.edufind.com/ENGLISH/GRAMMAR/Tenses2.cfm

------

Also, one definition of 'assert' is 'insist upon'.
Assert is insisting upon a single raise, not a group of raises
so why should it need to look like a plural noun rather than
what it is - a singular noun or a verb used from a singular
perspective?

Yes, it's contentious but the Ruby convention isn't without merit.

a = [ "a", "b", "c" ]
a.include?("b")  # true
a.include?("z")  # false
a.includes?("b")

rb172.tmp:4: undefined method `includes?' for ["a", "b", "c"]:Array 
(NoMethodError)


> I've rolled Nobu's change back, pending more dialog on the topic. My 
> preference is to have assert_raises and deprecate assert_raise. Barring 
> that, assert_raise could be an alias and stick around for those folk who 
> prefer it.
> 

I understand and may agree with your preference from an English
perspective only but, in Ruby, I'm used to expecting:

   assert_raise
   assert_include
   assert_throw
etc.

(No aliases)


Swallow hard and ignore English unless absolutely necessary :)

Thanks for your work.


daz