I had some problems with tests, specifically, several fail with:

rake RUBYARCHDIR=/tmp/test_rubygems_35162/gemhome/gems/a-2/lib  
RUBYLIBDIR=/tmp/test_rubygems_35162/gemhome/gems/a-2/lib
/Users/drbrain/Work/svn/ruby/trunk/rbconfig.rb:7: ruby lib version  
(1.9.0) doesn't match executable version (1.8.6) (RuntimeError)
	from /Users/drbrain/Work/svn/ruby/trunk/lib/rubygems.rb:60:in `require'
	from /Users/drbrain/Work/svn/ruby/trunk/lib/rubygems.rb:60
	from /usr/bin/rake:9:in `require'
	from /usr/bin/rake:9

Maybe I broke something merging the patches made to ruby trunk's  
rubygems back into the rubygems repository?

Testing is very difficult since my laptop has been broken.