On Sep 25, 2008, at 2:48 AM, Ryan Davis wrote:

> On Sep 24, 2008, at 03:17 , Yusuke ENDOH wrote:
>
>> In other instances, `assert_raise' is deprecated for unexplained  
>> reasons.
>> I think other issues will become clear during further use of  
>> miniunit.
>
> I just saw that Nobu rolled the undeprecated name from assert_raises  
> to assert_raise. Unfortunately the deprecation was NOT a typo and is  
> intentional. It is both a better English word choice and it is more  
> consistent with the other assertions (assert_includes,  
> assert_throws, etc).
>
> I've rolled Nobu's change back, pending more dialog on the topic. My  
> preference is to have assert_raises and deprecate assert_raise.  
> Barring that, assert_raise could be an alias and stick around for  
> those folk who prefer it.

I agree.  assert_raise() has always bothered me, grammar wise.

James Edward Gray II