On Sep 24, 2008, at 03:17 , Yusuke ENDOH wrote:

> Well, miniunit was added almost too late.

yeah. sorry. I got bummed after proposing with approval then  
reproposing and having it poo-poo'd (and eventually approved)... so I  
took a break from it and then dropped the ball until the deadline was  
announced.

> miniunit does not have enough experience with ruby 1.9.  I guess we  
> will
> need not only bug fix but also discussion/improvement that may involve
> change of behavior/specification.

Actually I'd been using multiruby to test it to ensure it passed on  
both 1.8 and 1.9. So in that sense it has experience. It only recently  
blew up because of the encoding changes... But I suspect you mean more  
with the 1.9 developers... THAT is absolutely true.

> For instance, I think readability of output of miniunit requires  
> greater
> consideration: use of pretty_inspect instead of inspect, appropriate  
> line
> feeds (when failure message is too long), etc.

pretty_inspect vs inspect: speed. This had a HUGE impact. If you  
override mu_pp(obj) you can change it as you deem appropriate. I  
certainly plan to for my sexp/parser code, but won't elsewhere.

appropriate line feeds: I simply didn't think about it. All the code  
I've been working on has HUGE output whether horizontal or vertical,  
so I have to use unit_diff to make it readable at all... I assume this  
mostly centers on your preference of pretty_inspect. Again, that can  
be addressed via mu_pp. I think I like leaving it up to the user so  
they can tweak as they deem appropriate. But I'm open to suggestions  
here.

> In other instances, `assert_raise' is deprecated for unexplained  
> reasons.
> I think other issues will become clear during further use of miniunit.

I just saw that Nobu rolled the undeprecated name from assert_raises  
to assert_raise. Unfortunately the deprecation was NOT a typo and is  
intentional. It is both a better English word choice and it is more  
consistent with the other assertions (assert_includes, assert_throws,  
etc).

I've rolled Nobu's change back, pending more dialog on the topic. My  
preference is to have assert_raises and deprecate assert_raise.  
Barring that, assert_raise could be an alias and stick around for  
those folk who prefer it.

> So I would suggest postponing miniunit freeze until the end of Oct.
> What do you think?

I'm fine with that... tho I doubt it will need that much dialog tho...  
We could probably set a freeze date 2-3 days after the next  
implementors meeting. I'll attend that so we can get this stuff  
resolved.

I'd like to simply say __Thank You__ to everyone who's given me  
feedback both here and on the Seattle.rb list. I really do appreciate  
it.