Hi,

In message "configure mkdir -p patch"
    on 03/11/30, Eric Sunshine <sunshine / sunshineco.com> writes:

|When I submitted the patch to revive the NeXT ports of Ruby a couple 
|months ago, one of the problems which the patch corrected was a bug in 
|Autoconf where the configure script leaves a bogus directory named '-p' 
|sitting at the top of the project tree on platforms for which 'mkdir' 
|does not recognize the '-p' option.  Unfortunately, this fix was never 
|committed. I was wondering if there was a reason for the omission or if 
|was merely an accidental oversight.
|
|The following m4 code, which corrects the problem, can be handled in one 
|of two ways.  The code can either be placed in a new aclocal.m4 file in 
|the project, or it can be inserted at the very top of configure.in 
|_before_ the call to AC_INIT().

autoconf is not for users, but developers, so that I thought it's OK
to ask developers to upgrade to autoconf 2.58 or later, rather than
adding bug fix files.

							matz.