On Aug 26, 2008, at 10:13 AM, Yusuke ENDOH wrote:
> 2008/8/27 Tanaka Akira <akr / fsij.org>:
>>> This is because Apache, which rubyforge uses, seems to handle
>>> If-Modified-Since field only when it is represented in GMT.
>>> This is not a fault of rubygems, but I think it's better for
>>> rubygems to convert last_modified in GMT.
>>
>> See HTTP-date definition of RFC 2616.
>
> Aha, this is a fault of rubygems X-(

I already fixed this in RubyGems trunk, but haven't got RubyGems  
stable enough to merge.