Hi,

In message "Re: [ruby-core:18384] New Command Revisted"

|If you do not like "File.absolute_path()",  have you
|considered adding a parameter to File.expand_path:
|
|I see two possibilities:
|
|1)   File.expand_path( file_name [, ABS  [, dir_string] ] )=20
|2)  File.expand_path( file_name [, dir_string  [, ABS] ] )
|
|     ---Where ABS is true for absolute path processing.

=46rom the past experience, adding a boolean flag as an argument is not
really a good idea for API design, since it hinders readability.  You
will have no clue to know what true mean in the future.  I'd take
absolute_path idea, rather than adding a boolean flag.

							matz.