Charles Oliver Nutter wrote:
> Brian Candler wrote:
>> If there are no good ideas left, perhaps things should be left as they 
>> are.
>> Or does that make me a heretic?
> 
> I find I frequently need to get only the second element of an array, or 
> perhaps the seventh. So perhaps if we have choice/pick/sample then we 
> should implement "second" through "tenth" as well. Maybe also powers of 
> ten beyond that... "tenth", "twentieth", "thirtieth". Maybe also 
> every_other, every_third, every_fourth so I can dice my arrays without 
> wearing _why's flip-flops.

Great idea! Why not just import the Rails code for dynamic finders into 
Ruby's Array, e.g.

   [1,2,3,4].get_second_and_third # => [2,3]

   [1,2,3,4].get_second_or_third # => [2] or [3] depending on random!!!

   [1,2,3,4].get_second_to_last # => [2,3,4]

This will produce much more readable sourcecode!!!

Regards,

   Michael

PS: I'm not serious :)